Online Training System Requirements FAQs

Frequently asked questions about the system requirements for our Online Training Platform.

What specification does my device need to be to use the online training platform?

Users can access our online learning space if:

  • They are on a Windows,¬†Chromebook,¬†Mac or IOS
  • They view the learning in Google Chrome, Firefox, Safari or Edge
  • Their device can run video and sound over HTML5 (H.264)
  • Their IT department does not cache our sites

  • IT ensure a connection through their proxy or firewall to:
    • launch.choota.com
    • launch.jcloudcontrol.com
    • YOURSITEURL .clcmoodle.org/clcflex.com
    • maxcdn.bootstrapcdn.com
    • fonts.gstatic.com
    • fonts.googleapis.com
    • ajax.aspnetcdn.com
    • *.vo.msecnd.net
    • cdnjs.cloudflare.com.

Users may not be able to our online learning space if:

  • Their IT Department heavily cache our addresses
  • Their IT department block our addresses
  • Their IT department do not whitelist our addresses
  • They view the learning on Windows XP running Internet Explorer
  • They may not have access to some materials without a soundcard/speakers/headphones
  • They have an unreliable internet connection
  • Their internet connection is less than 512kb a second
  • They view the learning in Internet Explorer 6,7,8, 9, 10 & 11
  • They use Safari 7 or below as they have known compatibility issues with Moodle 3.10.

Learn life saving skills

Have a look at our range of workplace and community first aid training courses.